Linux站群服务器维护操作方案笔记

服务器

Linux站群服务器维护操作方案笔记

目前,Linux站群服务器用的比较多,关于Linux站群服务器后续维护常见的问题我整理了一些对应的解决方案:

1、关于硬盘使用100%的问题

image-20230605092133956

Linux站群服务器,特别是泛站群服务器,因为生成大量缓存,特别容易出现硬盘被占用100%,解决方法主要有两步:

1.1、清除服务器缓存

Linux站群服务器多数是使用宝塔面板进行建站管理,可以使用SSH工具连接到服务器,使用宝塔清除缓存的命令

bt 15

image-20230605093126734

image-20230605093212004

等待命令执行完成后,会显示清除出多少磁盘空间;

一般Linux站群服务器,会安装免费的防火墙软件,像我安装的是宝塔提供的Nginx免费防火墙

image-20230605093345356

这个防火墙软件在工作的同时也会记录日志文件,时间久了,会记录非常多的日志文件,我们可以使用SSH工具批量清除这些日志文件:

先使用命令进入防火墙日志目录:

cd /www/wwwlogs/free_waf_log/

image-20230605093527602

然后执行清理当前目录所有的文件命令:

rm -rf ./*

image-20230605093641699

【提醒:执行这个命令前,一定要确保你当前是在防火墙日志的目录 free_waf_log】

日志清理完成之后,可以使用命令 df -h 查看服务器硬盘的使用情况,如下图:

/www 目录是我们存放网站源码的目录,目前显示可能只有20KB ,这个就表示 当前目录已经使用100%,全部被占用了;

其实,刚刚有清理出来几个GB的空间,但是这里还没有显示出来,重启一下nginx服务,再查看就可以了

service nginx restart

这个是重启nginx服务

查看服务器硬盘使用情况:

df -h

image-20230605093926222

这一次查询,可以看到硬盘的 /www 目录还剩下2.1GB可用空间;

清理服务器的日志,可以腾出一小部分可以使用的空间,需要更多硬盘使用空间,我们还得清除网站程序生成的缓存文件;

一般的网站程序,清除网站的缓存文件之后,相对应的网页内容就会发生变化、重新生成新的缓存,如果站群大部分内容都发生变化了,很可能直接导致站群流量大幅度下降,所以,我一般一次只清除20%左右的缓存文件;

1.2、清除程序缓存文件

不同站群程序,缓存文件存放的方式和路径不一样;

像小旋风的蜘蛛池程序,缓存文件存放的目录有:

temp/cache/html
temp/cache/htmlfile
temp/cache/theme
temp/cache/tplcache
temp/robotlog
temp/cache/tags
temp/cache/urlrules
temp/cache_collecturl

wordpress站点的缓存文件存放目录【启用了超级缓存插件,所以会生成缓存 】

wp-content/cache

现在我们通过配置5TB的服务器,去掉系统占用的空间外,剩下4.5TB的空间全部分配给 /www 目录,当缓存文件全部占满硬盘,其中一个缓存文件夹的大小大概有900GB, 所以通过删除一个文件夹需要的时间会非常长。

而且,偶尔还会出现一个问题:当我执行了删除缓存文件的命令时,硬盘的可用空间反而越来越小,通过是因为服务器上缓存文件生成的速度大于缓存文件被删除的速度,这个时候需要上传文件硬盘没有空间,我们可以暂时先停止 nginx 服务,然后删除缓存,大概5分钟就可以获得几个GB的空间,然后就可以上传文件了:

image-20230605104941613

上图是操作小旋风的站群服务器

在图1的位置,清理完日志文件之后 ,还是看不到有可能的硬盘空间;

在图2的位置,重启nginx服务,结果nginx服务停止后无法启动,这种情况通常是因为服务器的硬盘没有空间,导致nginx服务无法启动;

在图3的位置,进入到小旋风程序缓存目录,将html缓存目录改名 html11后,删除这个缓存目录;

差不多清理5分钟之后,使用快捷键 Ctrl+C 停止命令的执行,然后重启nginx服务,nginx服务启动之后再执行清除缓存目录的命令【因为Nginx服务在停止期间,服务器上所有的网站都是无法正常访问的,所以尽量不要长时间停止Nginx服务,否则 会影响网站的排名】

image-20230605110004134

上图命令操作解释:

图1的位置执行 快捷键Ctrl+C 停止上一行删除命令的执行;

图2的位置,执行 df -h 命令,查看服务器硬盘的使用情况,在图3的位置显示 /www 目录有5GB可用空间;

图4的位置,执行 service nginx restart 重启Nginx服务,在执行的结果中的第一行可以看出当前 nginx 服务是没有运行的,第二行显示 nginx 服务启动完成;

图5的位置,再次执行删除 html11缓存目录的命令;

1.3 升级宝塔面板时 提示 WARNING: You are using pip version 20.3.3; however, version 23.1.2 is available.

提示信息:

WARNING: You are using pip version 20.3.3; however, version 23.1.2 is available.
You should consider upgrading via the '/www/server/panel/pyenv/bin/python3.7 -m pip install --upgrade pip' command.
Requirement already satisfied: pymysql in ./pyenv/lib/python3.7/site-packages (0.9.3)
WARNING: You are using pip version 20.3.3; however, version 23.1.2 is available.
You should consider upgrading via the '/www/server/panel/pyenv/bin/python3.7 -m pip install --upgrade pip' command.

image-20230605103622384

这个提示信息是告诉我们 python 需要升级

可以使用命令:

/www/server/panel/pyenv/bin/python3.7 -m pip install --upgrade pip

image-20230605104006659

看到这个提示就表示 升级成功。

1.4、宝塔面板命令参数记录

在SSH工具中,连接到服务器之后, 执行bt命令,可以看到宝塔面板详细的命令参数:

image-20230605110411263

===============宝塔面板命令行==================
(1) 重启面板服务           (8) 改面板端口
(2) 停止面板服务           (9) 清除面板缓存
(3) 启动面板服务           (10) 清除登录限制
(4) 重载面板服务           (11) 设置是否开启IP + User-Agent验证
(5) 修改面板密码           (12) 取消域名绑定限制
(6) 修改面板用户名         (13) 取消IP访问限制
(7) 强制修改MySQL密码      (14) 查看面板默认信息
(22) 显示面板错误日志      (15) 清理系统垃圾
(23) 关闭BasicAuth认证     (16) 修复面板(检查错误并更新面板文件到最新版)
(24) 关闭动态口令认证          (17) 设置日志切割是否压缩
(25) 设置是否保存文件历史副本  (18) 设置是否自动备份面板
(0) 取消                   (29) 取消访问设备验证

输入bt命令之后,在命令参数解说的底部会让你输入你需要执行的命令编号 ,比如输入1,就会执行重启宝塔面板的命令,这个和在SSH工具里面直接输入 bt 1 是一样的效果,输入 bt 15 就是直接删除系统垃圾,输入 bt 16就是修复面板;

 

2、宝塔面板提示 【出错了,面板运行时发生错误】解决方法

登录宝塔面板之后,提示错误:

出错了,面板运行时发生错误!
软件列表格式不正确,已尝试修复,请重试!
>>点击查看详情

image-20230605095353290

修复这个错误,首先要保存服务器的硬盘有可用空间至少1GB,如果空间不足,可能会导致修复失败,空间不够的话可以按照上面的教程清理空间;

image-20230605100730942

这一台服务器清理了一天,清理出来269GB的空间,然后我们来执行修复宝塔的命令:

bt 16

一般情况下,5分钟左右就可以修复好

image-20230605100935886

看到这样的提示,宝塔面板就修复成功了。然后重新打开宝塔面板的登录地址,登录进去之后就不会再有那个错误提示了。

 

3、服务器常见问题判断

3.1、登录服务器的宝塔面板之后,首先查看宝塔面板首页各项服务是否正常启动:

image-20230605110940954

最重要的是上面标注的两项,Nginx 和 PHP , 正常启动的话,下面应该有一个绿色的三角形,没有启动的话是红色的双竖线;

上面的判断只是一个初步判断 ,可以配合服务器的流量使用情况组合判断 :

image-20230605111136717

如上图:PHP 和 Nginx显示是正常的,但是服务器的流量 上行 和 下行 的流量都持续小于 1000KB 那服务器很可能有问题;

image-20230605111340626

直接点击 Nginx 服务,可以打开 Nginx 管理面板,可以看到里面显示的状态是 关闭, 在Nginx关闭的情况下,服务器上所有的网站是都无法打开的,这个时候需要重启 Nginx 服务

Nginx 正常启动之后, 服务器的流量数据立马就不一样了:

image-20230605111606095

特别说明:

小旋风的站群服务器,服务有启动这三个:PHP 7.2, Nginx, Redis 这三项, 流量统计里面 上行、下行 通常都稳定在10万KB 也就是100MB 以上;

image-20230605111728748

WordPress的站群服务器,服务通常是有 PHP, Mysql, Nginx, 这三项,必须是启动状态;Wordpress是单站,在流量不高的情况下,上行和下行的流量都会比较小;【特别说明:如果有安装 phpMyAdmin , 平时一定要关闭这个服务,这个是用来管理数据库 的,但是容易被黑客入侵,所以平时不用的时候一定要关闭这个服务】

image-20230605112112339

 

4、服务器上的网站打开提示502错误 【502 Bad Gateway】

错误提示信息:

502 Bad Gateway
nginx

image-20230605165054060

服务器上网站打开提示502 bad Gateway 多数是php环境有点,一般重启一下php再回来刷新网站就可以了:

image-20230605165227391


【SEO业务合作】=》面向成长型与成熟品牌,提供全职SEO与兼职SEO灵活配置,支持远程办公,高效衔接内容、技术与外链;配套SEO经费支持,以可量化目标推进,表现优秀享提成奖金与长期激励。我们聚焦关键词策略、站点结构优化、内容集群、外链生态与转化提升,覆盖站内外全流程与数据跟踪,兼顾中文搜索场景与国际引擎需求,适配电商、资讯、SaaS与本地服务等多类型网站。欢迎企业、团队与个人洽谈SEO业务合作,打造稳健、可持续的自然流量增长路径。点击查看详细合作说明
服务器

评论

标题和URL已复制